Author Topic: Inconsistent Copy As A Web URL  (Read 1200 times)

Flashman

  • Sr. Member
  • ****
  • Posts: 51
Inconsistent Copy As A Web URL
« on: June 02, 2016, 03:48:50 PM »
I love Yummy but one area I find very frustrating is the way it handles Copy As A Web URL. On some domains it gives me the full path for an exact link and on others it just gives the basic www domain without including the http or any folders. Surely if you select an item and then select the option to Copy As a Web URL it should tell you the exact URL including the full path otherwise you may as well type it manually.






JD

  • Administrator
  • FTP Guru
  • *****
  • Posts: 2823
Re: Inconsistent Copy As A Web URL
« Reply #1 on: June 02, 2016, 05:08:08 PM »
Yes, obviously the feature is meant to copy the full URL. When this happens it means that the current path did not match the Remote Path and Web URL setting pair - the Web URL must represent the path to the home page at the Remote Path setting.

So, when you next have this happen check these settings and see what you've got. Usually I would see something like:

Remote Path : /public_html/
Web URL : http://www.mywebsite.com

Hope that helps?

Flashman

  • Sr. Member
  • ****
  • Posts: 51
Re: Inconsistent Copy As A Web URL
« Reply #2 on: June 02, 2016, 05:51:21 PM »
hmm, I've just been through all my bookmarks and there was a degree of inconsistency in some of the remote paths but I can see where I was going wrong now.

Under the web url you need the full url e.g. https://example.com/

Then under the initial path it works if I add a single /

Like that it's delivering the full and correct result when copied as a web url. My previous error was in sometimes showing the url as www without adding http:// and failing to add the trailing / both there in addition to the initial path.

I had some problems in cases where there is an additional sub folder with a dedicated bookmark. In those instances it required the full url including the sub folder. That same sub folder path also had to be added to the initial path and it works. It was just a bit more fiddly to setup. 

All fixed now  ;D

On a side note Yummy saves my bacon when certain FTP clients included in web design apps prove to be very unreliable...


JD

  • Administrator
  • FTP Guru
  • *****
  • Posts: 2823
Re: Inconsistent Copy As A Web URL
« Reply #3 on: June 02, 2016, 06:17:15 PM »
I guess it's a little finicky that feature, but once it's set right you don't need to worry again. I'll see if I can make it more tolerant of / requirements.

I contacted the vendor I think you mean to see if a Publish With... Yummy FTP (add your client here) feature could be co-developed but not heard back yet. Let's hope...

Flashman

  • Sr. Member
  • ****
  • Posts: 51
Re: Inconsistent Copy As A Web URL
« Reply #4 on: March 22, 2017, 01:13:30 PM »
Is it possible that a recent update has somehow broken this feature to copy as web url? I set up a new bookmark recently, but for the life of me I cannot get it to correctly copy as a web url, which is making the website building process a lot slower.

It lists the domain correctly, but nothing beyond that, so it will show up https://example.com/ but won't include direct links to pages, folders or individual files. I've looked at this for ages and cross referenced it against against other bookmarks to ensure they follow the same format, but no luck.

Curiously if I try the same thing as "Copy Url" it shows the full path to the selected file, but obviously not in a format that is right for what I need.


JD

  • Administrator
  • FTP Guru
  • *****
  • Posts: 2823
Re: Inconsistent Copy As A Web URL
« Reply #5 on: March 22, 2017, 05:11:33 PM »
Make sure the Initial Path setting is the real full path to the root of  your website - where your index page is. Then it should all Just Work :)

Flashman

  • Sr. Member
  • ****
  • Posts: 51
Re: Inconsistent Copy As A Web URL
« Reply #6 on: March 22, 2017, 05:23:52 PM »
On the other domains I have the initial path set as "/" and it works perfectly. On this domain it doesn't. I'll try sending you a screenshot.


davemacdo

  • Newbie
  • *
  • Posts: 1
Re: Inconsistent Copy As A Web URL
« Reply #7 on: March 31, 2017, 08:54:24 PM »
Just signed up for the forums after having the same problem and finding this thread.

This is not a very satisfactory solution, unfortunately. I am often using the same subdirectory (sometimes a deep one) of a site when I use YummyFTP for a site. This is often the case with media uploads. I have a saved YummyFTP bookmark that opens the folder on my Mac where the finished media files live and the folder on my server where I upload them. I would really like to be able to specify the starting point of the bookmark separately from the web directory. This is a pretty common feature of other FTP clients I've used in the past (Filezilla and Transmit).

JD

  • Administrator
  • FTP Guru
  • *****
  • Posts: 2823
Re: Inconsistent Copy As A Web URL
« Reply #8 on: March 31, 2017, 09:40:09 PM »
Hi davemacdo,

Flashman's last problem turned out to be that the initial path had managed to get a hidden carriage return in it, therefore making paths not match. He cleared the text and re-typed it to fix the problem.

I agree that there should be a separate setting for the base folder and I'll certainly get to that, but in the meantime make WebURL work as described using the Initial Path as the base folder, but to get the initially displayed folder functionality back, enable the 'Restore last visited folders' option in the Interface panel of the Preferences - when enabled, the current local and remote folder is recorded in the Bookmark when you close the FTP Browser, and when you open the Bookmark again both the local and remote sides will be restored.