Author Topic: 'PORT' Command not implemented  (Read 4090 times)

sawestwood

  • Jr. Member
  • **
  • Posts: 4
'PORT' Command not implemented
« on: July 24, 2016, 11:19:42 AM »
Everytime I try to upload files I keep getting the following error message

'PORT': command not implemented

It must be doing something as the pages I am trying to overwrite  have now vanished!

I have tried all the usual login / log off, shut down etc.  Even gone direct into 1&1 and deleted some files in case my server was full but still no joy.

Can someone please help?

JD

  • Administrator
  • FTP Guru
  • *****
  • Posts: 2845
Re: 'PORT' Command not implemented
« Reply #1 on: July 24, 2016, 01:09:31 PM »
Re-enable the Use Passive (PASV) checkbox in your Bookmark. For some reason your server doesn't support on of the basic commands of FTP and the 1&1 support people should have known that, quite honestly.

sawestwood

  • Jr. Member
  • **
  • Posts: 4
Re: 'PORT' Command not implemented
« Reply #2 on: July 25, 2016, 06:05:37 AM »
Thank you.  It was already checked if you mean the one on the login screen.  So I tried it checked and un-checked and still wont work?

JD

  • Administrator
  • FTP Guru
  • *****
  • Posts: 2845
Re: 'PORT' Command not implemented
« Reply #3 on: July 25, 2016, 08:08:22 AM »
In that case please repeat the problem then select Save FTP Transcript from the File menu and send me the resulting file. This will show what is happening.

You can mail me : support@yummysoftware.com

sawestwood

  • Jr. Member
  • **
  • Posts: 4
Re: 'PORT' Command not implemented
« Reply #4 on: July 25, 2016, 05:08:39 PM »
<< Connection : 1 >>
<< Date Time : 25/7/16 17:04:41 >>
220 FTP Server ready.
USER u49186730
<< Date Time : 25/7/16 17:04:42 >>
331 Password required for u49186730
PASS ************
230 User u49186730 logged in
SYST
215 UNIX Type: L8
OPTS UTF8 ON
500 'OPTS': command unrecognized.
PWD
257 "/" is the current directory
TYPE A
200 Type set to A
PASV
227 Entering Passive Mode (217,160,233,90,194,112).
LIST -la
150 Opening ASCII mode data connection for file list
<< Date Time : 25/7/16 17:05:29 >>
220 FTP Server ready.
USER u49186730
331 Password required for u49186730
PASS ************
230 User u49186730 logged in
OPTS UTF8 ON
500 'OPTS': command unrecognized.
CWD /
250 CWD command successful
PWD
257 "/" is the current directory
TYPE A
200 Type set to A
PORT 192,168,1,2,219,132
502 'PORT': command not implemented.


Thank You

JD

  • Administrator
  • FTP Guru
  • *****
  • Posts: 2845
Re: 'PORT' Command not implemented
« Reply #5 on: July 25, 2016, 07:09:52 PM »
Ok, this shows Yummy trying to get a file listing in Passive (PASV) mode but the connection never makes it and so Yummy disconnects and retries using Active (PORT) mode which then fails because the server doesn't support it.

So the original problem is that the connection times out to your server. Perhaps it's really slow to make the connection, so try increasing the timeout value to 120 secs - that's the top slider in the Error Recovery panel of the Preferences, close the windows and try again.

If that still doesn't work then I would guess there is a firewall issue somewhere preventing the connection and then I would ask - can you connect with any other FTP app?

sawestwood

  • Jr. Member
  • **
  • Posts: 4
Re: 'PORT' Command not implemented
« Reply #6 on: August 09, 2016, 11:26:37 AM »
Connection is hit and miss, with it working yesterday but today I can not even log in.  I get a "PORT" command not implemented error message failure when logging in or I get in and then I can't open the folders I have on the server.
If I use my ISPs FTP program or go into 1&1 direct I can upload files no problem.  I thought it may have been my slow internet speed at 1mps but I have just upgraded to fiber and getting 20mps upload speed has not solved the problem.

I'm on a Mac if that makes any difference?

JD

  • Administrator
  • FTP Guru
  • *****
  • Posts: 2845
Re: 'PORT' Command not implemented
« Reply #7 on: August 09, 2016, 05:05:38 PM »
I only make Mac software, so it makes no difference :)

The problem is still that Yummy is trying to use the PORT command and your server doesn't support it.

So to avoid use of the PORT command at all do this :

1. In the Preferences -> Server Options make sure 'Auto-detect Active/Passive mode' is un-checked and 'Default to Passive FTP (PASV)' is checked, then close the Preferences window.

2. In your Bookmark settings make sure that 'Use passive FTP (PASV)' is checked in the Basic tab. If the Basic/Advanced/etc tabs aren't showing click the disclosure button at the bottom left of the settings window.

These two changes should ensure the problem server never gets the PORT command again.